`

杭电---2141

c 
阅读更多

Problem Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".

Sample Input

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

Sample Output

Case 1:
NO
YES
NO
运用二分的思想;
#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 510
int a[maxn],b[maxn],c[maxn];
int sum[maxn*maxn];
int bin_search(int y,int cnt)
{
    int left=0,right=cnt-1;
    int mid;
    while(left<=right)
    {
        mid=(left+right)/2;
        if(sum[mid]==y) return 1;
        if(sum[mid]<y) left= mid+1;
        if(sum[mid]>y) right=mid-1;
    }
    return 0;
}
int main ()
{
    int l,m,n;
    int k=1;
    while(~scanf("%d%d%d",&l,&m,&n))
    {
        for(int i=0; i<l; i++)
            scanf("%d",&a[i]);
        for(int i=0; i<m; i++)
            scanf("%d",&b[i]);
        for(int i=0; i<n; i++)
            scanf("%d",&c[i]);
        int cnt=0;
        for(int i=0; i<l; i++ )
            for(int j=0; j<m; j++)
            {
                sum[cnt++]=a[i]+b[j];

            }
        sort(sum,sum+cnt);\\sort是一个排序函数,可以自己百度了解一下
        int s;
        scanf("%d",&s);
        printf("Case %d:\n",k++);
        while(s--)
        {
            int x;
            scanf("%d",&x);
            int flag=0;
            for(int i=0; i<n; i++)
            {
                if(bin_search(x-c[i],cnt))
                {
                    flag=1;
                    break;
                }
            }
            if(flag==1)printf("YES\n");
            else printf("NO\n");
        }
    }
    return 0;
}
\\Ai+Bj+Ck = X可以写成Ai+Bj=X-Ck;


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics